
Loading charts in Seaclear II

The SeaClear program itself does not contain any charts (apart from one greenish very basic 
world chart). The location of the new charts must be allocated to the program through the 
“Autoload list” This allocation must be done by using the tandem program “Mapcal”. The 
“MapCal” utility can be found in the same directory as SeaClear.

You must differentiate between BSB raster charts which have already been geo-referenced by 
the publisher, (cont at 1.1.) and scanned charts (straight from the scanner) that have not yet 
been geo-referenced. (cont at 1.3)

1.1  Loading BSB raster charts step by step.
1. Copy the cruising region folder(s) from the DVD to the hard disk or create chart 

folders (directories) using Windows Explorer (or another file manager program such as 
My Computer) and then copy the chart files into the folders.

2. SeaClear works best if you copy the appropriate chart file(s) from the DVD to the 
folder C:\Program Files\SeaClear\charts, but other file locations can also be used. Make a 
logical directory structure. 

3. Start the tandem utility “Mapcal” by double clicking on its icon
4. Select: “Tools > Set Directories”   (Set Directories is used for setting all file paths 

used by MapCal and SeaClear.)
5. In the Chart Directories window, enter the path to the chart folders you created earlier, 

or click the Browse for Folder button [ << ] box to the right of the Chart Directories 
window to navigate to your chart folders.

6. Select the chart folder you would like to add and click OK. If you have copied the 
charts to multiple directories for different regions, click the requested directories one by 
one and OK each one.

7. Click OK in the Set Directories window to close the window.

1.2 Making the Autoload List  (identical procedure for BSB or WCI charts)
The “Autoload list” is the database in which all charts are listed that can be used by Seaclear.
Before the Autoload list is made, it is important that all calibrated chart files are located in the 
right directories. (see above)  This should be done using standard Windows tools, like 
Explorer or Commander.  

NB:  Non-calibrated charts must be filed in other directories, an cannot be used for 
navigation

The in the Mapcal utility clicking on “Tools > Set Directories” will bring up a list of 
directories in which the charts can be found. Click and OK all required directories one by one.

If all directories have been entered correctly, the charts are now ready to be included in the 
Autoload list.  Click “Tools > Autoload list > Scan for new charts”  
Mapcal now starts scanning all listed directories, this can take a few minutes so be patient..
Finally a scan report appears, showing the number of  KAP/GEO (=BSB) charts found, the 
number of WCI charts found and some other relevant information.



With this function only new found charts are added to the Autoload list. 
It is usually better (for instance when the new season starts) to clear the “Autoload list” 
completely and start again from scratch by clicking on  “Tools > Autoload list > Recreate” 
Everytime SeaclearII is started, it will look in the Autoload list, for charts that are available 
for navigation. If a chart is not included in the list, it will not be used for navigation.

In SeaclearII the contents of the Autoload list can always be checked, by clicking on  “File > 
Charts > List All”   

1.3  Geo referencing (calibrating) of scanned charts
Scanned charts must be “Geo- referenced” or “Calibrated” also using the tandem program 
Mapcal. This is achieved by adding a Lat-Lon grid to the chart and defining the chart borders. 
The GPS orients itself on this grid and the chart itself  “underlays” this grid. 
The grid itself can be fixed to the chart by defining at least 2 Lat-Lon points of which the 
exact coordinates are known. Usually these points are the crossings of printed gridlines. In 
practice you should use at least 4 points close to the four corners of the chart.
In order to check the correct geo-referencing a pink grid can be projected over the chart. All 
lines of the grid should match the coordinates as printed on the chart edges as accurately as 
possible. Thereafter the chart edge (border) must be defined. Both data are stored within the 
chart file on saving the calibration.
BSB charts have already been geo-referenced, calibration points are visible but cannot be 
changed by the user.

The procedure is as follows: 

When Mapcal is started the following screen appears:



 

1.4 Loading a chart file 
All TIFF, BMP and PNG files can be loaded, but loading BMP files works best. 
However it is recommended to first convert all available scanned files into the WCI format 
using the “Tools > Convert > Images in directory” command. The WCI format is proprietary 
to Seaclear and can only be read by Seaclear. It is a highly compressed file format (factor 10 – 
20 reduction in file size).  
WCI files can always be converted back to the more universal BMP format. 

If all available files are converted into WCI format, they are ready for calibration and can be 
loaded one by one. Use the “File > Open chart” command. 
When uncalibrated charts are loaded for the first time, a “Chart Information” pop-up screen is 
shown first.    See section 1.9
NB:   If the chart info box does not appear, the chart has probably already been calibrated.

1.5 Geo- referencing (calibrating) a chart 
Load a WCI chart and place the cursor on a point with known coordinates. Usually a crossing 
between a meridian line and latitude line can be used, and then round numbers can be filled 
in. However it is still possible to use any other position on the chart as a geo-reference point, 
as long as the coordinates are accurately known. The best is to use four positions on the chart 
wide apart, preferably near the four corners. Addition calibration points can be added near 
critical navigation area’s such as Capes, Harbours or narrow entrances. 

Place the cursor on a calibration point, click right and click “Add New Cal. Point” 



Accurate alignments can be made using the arrow keys. Enter the exact coordinates in the 
respective boxes. Usually four points are enough. Don’t add more than 10 points to achieve 
good calibration. If the grid still does not match properly, erase all points and start from 
scratch. 

1.6 View the calibration grid
Choose “Normal Grid” and “Activate changes” to show the overlay grid.  Check alignment on 
all chart edges and near critical navigation area’s.  The grid should be regular and rectangular. 
If not the Lat-Lon data are in error, check again. 
Any black calibration point can be recalibrated by moving the cursor towards that point and 
right-click “Select Closest”, the point turns red and can be modified (both position and geo- 
data can be changed).

If done, click “Activate Changes” 
and check the new grid position 
again. Repeat this procedure a few 
times to make sure the grid lines up 
properly with all lines in the chart.

1.7 Local adjustment of the grid.
In case of inaccurately scanned 
charts, small deviations can be 
corrected by adding more 
calibration points, and “stretching” 
the grid locally to match the chart. 
However this procedure should not 
be encouraged since errors are 
easily introduced.
It is usually better to re-scan the 
chart properly and start from 
scratch.



1.8 Chart Borders
The borders of the chart must be indicated so that Seaclear knows where the chart begins and 
ends. New charts can be loaded by Seaclear when needed, if we are likely to sail over the 
chart edge. To enter the chart border data, first select the “border” tab and place four border 
points on the chart borders, using the same procedure as for the calibration points. Borders 
should be placed on or near to the Lat-Lon scale edges of the chart and preferably not on the 
bold black line surrounding the chart. This will prevent sailing over non charted area’s prior 
to loading the next chart.  In case of non rectangular charts, additional border points can be 
placed as needed.

1.9 Entering additional chart information

Select:  “Edit > Chart information” and the following window appears:

Most fields are self explanatory, but they all should be filled in.



Projection
It is important to enter the correct projection otherwise large calibration errors will result. 
Never leave this box to “unknown”. Nowadays most nautical charts will have Mercator 
projection. Mercator charts have a variable vertical scale according to latitude, so Mercator 
should be selected from the drop down list. Other projections are less common. If in doubt use 
Mercator. 

Chart Datum
The “chart datum” is always printed on the chart and should be selected from the drop down 
list. Filling in the wrong chart datum could result in position errors of a few hundred feet. 
Recent charts all have WGS 84 as chart datum, but older charts show sometimes Transverse 
Mercator, Polyconic or Gauss.  If in doubt use WGS84.

Scale and Priority
Filling in scale and priority are related. Filling in the scale of the chart is necessary to get the 
right chart on the screen depending on your position. Do not leave the scale at the default 
200.000, but fill in the actual scale.  If priority is left at 1, Seaclear will search for the smallest 
available (most detailed) chart in the database. Higher numbers mean lower priority.  So if 
you have older or less relevant charts in your database, give them a higher number.

Depth
Should be filled in but has no influence on the navigation. Older BA charts are grey-white and 
depths are in Fathoms. More recent charts are in yellow-blue-green white and are in meters.

Other information
All information relevant to that particular chart can be listed here such as digitising date or 
other special remarks for that particular navigation area

Summary  for geo-referencing (calibrating) scanned charts
1. Place all scans in the selected chart directory. Scans preferably to be filed as BMP.
2. Convert all scanned charts to WCI format using  “Tools > Convert > Images in 

directory”
3. Open the “Mapcal” utility and load WCI chart file from the list by selecting “File > 

Open Image”
4. Open the  "Edit > Chart Information"  window (if it has not already been opened).
5. Enter the correct scale of the chart, and chose a priority (higher number = lower 

priority)
6. Select “Chart projection” from the drop down list.    If unknown use Mercator. 
7. Select  “Chart Datum” from the drop down list.          If unknown use WGS84.
8. Fill in Lat-Lon shift   (very seldom used and prone to serious errors.  (if in doubt leave 

at 000.00.00 ) 
9. Click OK. That will close the chart information window.
10. Add at least 2 separate calibration points in the chart (better is 4) together with their 

positions. Right-click and select “Add new cal. Point” for each new point.
11. Click on “Normal grid” and then on “Activate changes”, so the pink grid becomes 

visible
12. Check grid over chart with Lat-Lon scales on the sides of the chart, correct where 

needed
13. Check correct calibration in the centre of the chart and near critical navigation area’s



14. If necessary add additional cal. Points and “strech” the grid to match the chart.
15. Select “Border” and enter at least 4 border points. Can also be done quickly by “Set 

border to image” 
16. Click on "Save Calibration". The Chart is now ready for navigation in Seaclear.

1.10 Handling WCI, BMP, TIFF or JPEG files
The data in the “Chart Information” window can always be changed, but then the file should 
then be saved again. The WCI chart file can at any time be converted back into a .BMP file. 
This can be very useful if small sections of the main chart contain other small scale charts that 
need to be cut out from the main chart and to be calibrated separately. BMP files can be 
converted in TIFF or JPEG files. A nice and fast program for handling large graphic BMP or 
TIFF files is “Irfanview”  
These file formats can best be converted back to WCI format using the Mapcal batch file 
conversion utility  “Tools > Convert > Images in directory” 
.
PDF files cannot be handled by Mapcal unless they are first converted to BMP or TIFF.
JPEG files should be avoided since in combination with WCI conversion they will show a 
very “rough” texture or unsatisfactory graphics.

1.11 Converting back to 
BMP
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